Linux

Problema con Eclipse Mars en Ubuntu 16.04

Si estás teniendo problemas con Eclipse Mars en Ubuntu 16.04, en plan no te abre bien las preferencias, no hace conexiones GIT… no te desesperes más.

Por lo visto hay un error con al versión de GTK+3.

Para empezar, abre un terminal y escribe el siguiente comando:

export SWT_GTK3=0

Si te ha funcionado, puedes hacer una modificación persistente, ya que la anterior era sólo temporal. En la carpeta raíz de eclipse, edita el archivo eclipse.ini. Inserta las 2 siguientes líneas:

--launcher.GTK_version
2

Insértalas justo antes de esta línea:

--launcher.appendVmargs

Con esto ya debería funcionar correctamente 🙂


Fuente askubuntu.com

Anuncios
Linux

Tras instalar Ubuntu aparece al iniciar ‘Please enter passphrase for disk…’

Al instalar Ubuntu en un disco duro tipo SSD puede que se te presente este mensaje al iniciar:

http://i.imgur.com/yhtfLRd.jpg

Da igual que lo dejes en blanco o que pongas alguna contraseña porque, siempre, pero siempre siempre, te la volverá a pedir al arrancar el SO.

Googleando un poco di con la solución:

  1. Encuentra la partición que es swap:
    sudo fdisk -l

    Te aparecerá algo parecido a esto:

    sudo fdisk -l
    [sudo] password for kempe: 
    
    Disk /dev/sda: 233,8 GiB, 251000193024 bytes, 490234752 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: B59D4149-AC8E-4B71-B51F-8926B2E82C14
    
    Device         Start       End   Sectors   Size Type
    /dev/sda1       2048    409599    407552   199M EFI System
    /dev/sda2     409640 253319775 252910136 120,6G Apple HFS/HFS+
    /dev/sda3  253321216 269320191  15998976   7,6G Linux swap
    /dev/sda4  269320192 490233855 220913664 105,3G Linux filesystem
  2. En este caso, el dispositivo es /dev/sda3. En tu caso no tiene que ser el mismo, por lo que tienes que seleccionar el que sea de tipo ‘Linux swap’.
  3. Desactiva el swap:
    sudo swapoff -a
  4. Dehabilita cryptswap:
    sudo cryptsetup remove /dev/mapper/cryptswap1
  5. Elimina la línea correspondiente de ‘/etc/crypttab’. Esta línea es en la que aparezca tu dispositivo, en mi cas ‘/etc/sda3’ Usa ‘vi’, ‘vim’ o ‘nano’ (éste es el más fácil de usar).
    sudo nano /etc/crypttap
  6. Establece la nueva área swap:
    sudo /sbin/mkswap /dev/sda3
    
    sudo swapon /dev/sda3
  7. Y, finalmente, modifica la línea fstab, reemplazando ‘/dev/mapper/cryptswap1’ por tu dispositivo, en mi caso, ‘/dev/sda3’:
    sudo nano /etc/fstab

Problemas que se me presentaron tras hacer esto:

El servicio de red inalámbrica no siempre se inicia al arrancar Ubuntu. Al menos, esto ocurre en el Dell XPS 13 (9350). Si esto sucede, basta con hacer:

sudo service networking restart && sudo service network-manager restart

Fuente – askubuntu.com